feel free to keep it strictly simple...

lib_comp: usage

Lib_comp offers some code to make old addons compatible with current LEPTON installation, starting with LEPTON 5.

As some old methods, functions and engines had been removed with LEPTON 5 we neeed an easy way to make addons work with this release without coding everything new.

You simply have to place the following code into every file of your addon or - where possible (like bakery) - in a file that is loaded with every page (addon config file):

//  L* 5 backward compatibility for outdated modules

if(class_exists("lib_comp", true))
{
    lib_comp::init("bakery");
}

last edit: 22/01/2021 - 15:06